What’s Vulnerable › Vulnerabilities
CVE-2014-2270
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-03-14 · updated 2026-06-17
- Weakness: CWE-119
Description
softmagic.c in file before 5.17 and libmagic allows context-dependent attackers to cause a denial of service (out-of-bounds memory access and crash) via crafted offsets in the softmagic of a PE executable.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.10
- Debian Linux: 6.0, 7.0, 8.0
- File Project File: before 5.17 — fixed in 5.17
- Opensuse: 11.4, 12.3, 13.1
- PHP: before 5.4.26; from 5.5.0 before 5.5.10 — fixed in 5.4.26, 5.5.10
How to fix
Upgrade to a fixed version: File Project File 5.17; PHP 5.4.26, 5.5.10. Check the vendor advisory for mitigations.
References
- http://bugs.gw.com/view.php?id=313
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00034.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00037.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00084.html
- http://rhn.redhat.com/errata/RHSA-2014-1765.html
- http://seclists.org/oss-sec/2014/q1/473
- http://seclists.org/oss-sec/2014/q1/504
- http://seclists.org/oss-sec/2014/q1/505
- http://support.apple.com/kb/HT6443
- http://www.debian.org/security/2014/dsa-2873
- http://www.php.net/ChangeLog-5.php
- http://www.ubuntu.com/usn/USN-2162-1
Get alerted when CVE-2014-2270 or the next vulnerability affects your stack