What’s Vulnerable › Vulnerabilities
CVE-2014-2323
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 62.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-03-14 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- lighttpd: before 1.4.35 — fixed in 1.4.35
- Opensuse: 11.4, 12.3, 13.1
- SUSE Linux Enterprise High Availability Extension: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: lighttpd 1.4.35. Check the vendor advisory for mitigations.
References
- http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2014_01.txt
- http://jvn.jp/en/jp/JVN37417423/index.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2014-04/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2014-04/msg00006.html
- http://marc.info/?l=bugtraq&m=141576815022399&w=2
- http://seclists.org/oss-sec/2014/q1/561
- http://seclists.org/oss-sec/2014/q1/564
- http://secunia.com/advisories/57404
- http://secunia.com/advisories/57514
- http://www.debian.org/security/2014/dsa-2877
- http://www.lighttpd.net/2014/3/12/1.4.35/
Get alerted when CVE-2014-2323 or the next vulnerability affects your stack