What’s Vulnerable › Vulnerabilities

CVE-2014-2497

Description

The gdImageCreateFromXpm function in gdxpm.c in libgd, as used in PHP 5.4.26 and earlier, allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted color table in an XPM file.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.32, 5.5.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-2497 or the next vulnerability affects your stack