What’s Vulnerable › Vulnerabilities
CVE-2014-2550
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-19 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-site request forgery (CSRF) vulnerability in the Disable Comments plugin before 1.0.4 for WordPress allows remote attackers to hijack the authentication of administrators for requests that enable comments via a request to the disable_comments_settings page to wp-admin/options-general.php.
Affected products
- Disable Comments Project: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Disable Comments Project 1.0.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/92219
- https://security.dxw.com/advisories/csrf-in-disable-comments-1-0-3/
- https://wordpress.org/plugins/disable-comments/#developers
- https://exchange.xforce.ibmcloud.com/vulnerabilities/92219
- https://security.dxw.com/advisories/csrf-in-disable-comments-1-0-3/
- https://wordpress.org/plugins/disable-comments/#developers
Get alerted when CVE-2014-2550 or the next vulnerability affects your stack