What’s Vulnerable › Vulnerabilities
CVE-2014-2686
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-09 · updated 2026-06-17
- Weakness: CWE-670
Description
Ansible prior to 1.5.4 mishandles the evaluation of some strings.
Affected products
- Red Hat Ansible: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.5.4. Check the vendor advisory for mitigations.
References
- https://groups.google.com/forum/#%21searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ
- https://groups.google.com/forum/#%21searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ
Get alerted when CVE-2014-2686 or the next vulnerability affects your stack