What’s Vulnerable › Vulnerabilities
CVE-2014-2845
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-15 · updated 2026-06-17
- Weakness: CWE-295
Description
Cyberduck before 4.4.4 on Windows does not properly validate X.509 certificate chains, which allows man-in-the-middle attackers to spoof FTP-SSL servers via a certificate issued by an arbitrary root Certification Authority.
Affected products
- Cyberduck: before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: Cyberduck 4.4.4. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/58426
- http://www.securityfocus.com/archive/1/532039/100/0/threaded
- https://cyberduck.io/changelog/
- http://secunia.com/advisories/58426
- http://www.securityfocus.com/archive/1/532039/100/0/threaded
- https://cyberduck.io/changelog/
Get alerted when CVE-2014-2845 or the next vulnerability affects your stack