What’s Vulnerable › Vulnerabilities
CVE-2014-2897
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-125
Description
The SSL 3 HMAC functionality in wolfSSL CyaSSL 2.5.0 before 2.9.4 does not check the padding length when verification fails, which allows remote attackers to have unspecified impact via a crafted HMAC, which triggers an out-of-bounds read.
Affected products
- wolfSSL: from 2.5.0 before 2.9.4 — fixed in 2.9.4
How to fix
Upgrade to a fixed version: wolfSSL 2.9.4. Check the vendor advisory for mitigations.
References
- http://seclists.org/oss-sec/2014/q2/126
- http://seclists.org/oss-sec/2014/q2/130
- http://www.wolfssl.com/yaSSL/Blog/Entries/2014/4/11_wolfSSL_Security_Advisory__April_9%2C_2014.html
- http://www.wolfssl.com/yaSSL/Docs-cyassl-changelog.html
- http://seclists.org/oss-sec/2014/q2/126
- http://seclists.org/oss-sec/2014/q2/130
- http://www.wolfssl.com/yaSSL/Blog/Entries/2014/4/11_wolfSSL_Security_Advisory__April_9%2C_2014.html
- http://www.wolfssl.com/yaSSL/Docs-cyassl-changelog.html
Get alerted when CVE-2014-2897 or the next vulnerability affects your stack