What’s Vulnerable › Vulnerabilities
CVE-2014-2901
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-21 · updated 2026-06-17
- Weakness: CWE-295
Description
wolfssl before 3.2.0 does not properly issue certificates for a server's hostname.
Affected products
- wolfSSL: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: wolfSSL 3.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/04/18/2
- https://security-tracker.debian.org/tracker/CVE-2014-2901
- http://www.openwall.com/lists/oss-security/2014/04/18/2
- https://security-tracker.debian.org/tracker/CVE-2014-2901
Get alerted when CVE-2014-2901 or the next vulnerability affects your stack