What’s Vulnerable › Vulnerabilities
CVE-2014-2983
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-23 · updated 2026-06-17
- Weakness: CWE-200
Description
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- Drupal: from 6.0 before 6.31; from 7.0 before 7.27 — fixed in 6.31, 7.27
How to fix
Upgrade to a fixed version: Drupal 6.31, 7.27. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2014/dsa-2913
- http://www.debian.org/security/2014/dsa-2914
- http://www.openwall.com/lists/oss-security/2014/04/22/2
- https://drupal.org/SA-CORE-2014-002
- http://www.debian.org/security/2014/dsa-2913
- http://www.debian.org/security/2014/dsa-2914
- http://www.openwall.com/lists/oss-security/2014/04/22/2
- https://drupal.org/SA-CORE-2014-002
Get alerted when CVE-2014-2983 or the next vulnerability affects your stack