What’s Vulnerable › Vulnerabilities
CVE-2014-3120: Elasticsearch Remote Code Execution Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 88.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-07-28 · updated 2026-06-17
- Weakness: CWE-284
Description
The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to _search. NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.
Affected products
- Elasticsearch: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Elasticsearch 1.2.0. Check the vendor advisory for mitigations.
References
- http://bouk.co/blog/elasticsearch-rce/
- http://www.exploit-db.com/exploits/33370
- http://www.osvdb.org/106949
- http://www.rapid7.com/db/modules/exploit/multi/elasticsearch/script_mvel_rce
- http://www.securityfocus.com/bid/67731
- https://www.elastic.co/blog/logstash-1-4-3-released
- https://www.elastic.co/community/security/
- https://www.found.no/foundation/elasticsearch-security/#staying-safe-while-developing-with-elasticsearch
- http://bouk.co/blog/elasticsearch-rce/
- http://www.exploit-db.com/exploits/33370
- http://www.osvdb.org/106949
- http://www.rapid7.com/db/modules/exploit/multi/elasticsearch/script_mvel_rce
Get alerted when CVE-2014-3120 or the next vulnerability affects your stack