What’s Vulnerable › Vulnerabilities
CVE-2014-3181
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-09-28 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple stack-based buffer overflows in the magicmouse_raw_event function in drivers/hid/hid-magicmouse.c in the Magic Mouse HID driver in the Linux kernel through 3.16.3 allow physically proximate attackers to cause a denial of service (system crash) or possibly execute arbitrary code via a crafted device that provides a large amount of (1) EHCI or (2) XHCI data associated with an event.
Affected products
- Linux kernel: from 2.6.37 before 3.2.63; from 3.3 before 3.4.104; from 3.5 before 3.10.56; from 3.11 before 3.12.31; from 3.13 before 3.14.20; from 3.15 before 3.16.4 — fixed in 3.10.56, 3.12.31, 3.14.20, 3.16.4, 3.2.63, 3.4.104
How to fix
Upgrade to a fixed version: Linux kernel 3.10.56, 3.12.31, 3.14.20, 3.16.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=c54def7bd64d7c0b6993336abcffb8444795bf38
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://rhn.redhat.com/errata/RHSA-2014-1318.html
- http://www.openwall.com/lists/oss-security/2014/09/11/21
- http://www.securityfocus.com/bid/69779
- http://www.ubuntu.com/usn/USN-2376-1
- http://www.ubuntu.com/usn/USN-2377-1
- http://www.ubuntu.com/usn/USN-2378-1
- http://www.ubuntu.com/usn/USN-2379-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1141173
- https://code.google.com/p/google-security-research/issues/detail?id=100
Get alerted when CVE-2014-3181 or the next vulnerability affects your stack