What’s Vulnerable › Vulnerabilities

CVE-2014-3182

Description

Array index error in the logi_dj_raw_event function in drivers/hid/hid-logitech-dj.c in the Linux kernel before 3.16.2 allows physically proximate attackers to execute arbitrary code or cause a denial of service (invalid kfree) via a crafted device that provides a malformed REPORT_TYPE_NOTIF_DEVICE_UNPAIRED value.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.54, 3.12.28, 3.14.18, 3.16.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-3182 or the next vulnerability affects your stack