What’s Vulnerable › Vulnerabilities
CVE-2014-3185
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-09-28 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple buffer overflows in the command_port_read_callback function in drivers/usb/serial/whiteheat.c in the Whiteheat USB Serial Driver in the Linux kernel before 3.16.2 allow physically proximate attackers to execute arbitrary code or cause a denial of service (memory corruption and system crash) via a crafted device that provides a large amount of (1) EHCI or (2) XHCI data associated with a bulk response.
Affected products
- Linux kernel: before 3.2.63; from 3.3 before 3.4.104; from 3.5 before 3.10.54; from 3.11 before 3.12.29; from 3.13 before 3.14.18; from 3.15 before 3.16.2 — fixed in 3.10.54, 3.12.29, 3.14.18, 3.16.2, 3.2.63, 3.4.104
How to fix
Upgrade to a fixed version: Linux kernel 3.10.54, 3.12.29, 3.14.18, 3.16.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=6817ae225cd650fb1c3295d769298c38b1eba818
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00020.html
- http://rhn.redhat.com/errata/RHSA-2014-1318.html
- http://rhn.redhat.com/errata/RHSA-2015-0284.html
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.16.2
- http://www.openwall.com/lists/oss-security/2014/09/11/21
- http://www.securityfocus.com/bid/69781
- http://www.ubuntu.com/usn/USN-2374-1
- http://www.ubuntu.com/usn/USN-2375-1
Get alerted when CVE-2014-3185 or the next vulnerability affects your stack