What’s Vulnerable › Vulnerabilities
CVE-2014-3248
- Severity: medium (CVSS 6.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-11-16 · updated 2026-06-17
- Weakness: CWE-17
Description
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
Affected products
- Puppet Facter: 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4, 2.0.1, 2.0.1-rc1 (+3)
- Puppet Hiera: before 1.3.4 — fixed in 1.3.4
- Puppet Marionette Collective: before 2.5.2 — fixed in 2.5.2
- Puppet Agent: before 2.7.26; from 3.6.0 before 3.6.2 — fixed in 2.7.26, 3.6.2
- Puppet Enterprise: from 2.8.0 before 2.8.7 — fixed in 2.8.7
- Puppetlabs Facter: from 1.6.0 through 1.6.18
How to fix
Upgrade to a fixed version: Puppet Hiera 1.3.4; Puppet Marionette Collective 2.5.2; Puppet Agent 2.7.26, 3.6.2; Puppet Enterprise 2.8.7. Check the vendor advisory for mitigations.
References
- http://puppetlabs.com/security/cve/cve-2014-3248
- http://rowediness.com/2014/06/13/cve-2014-3248-a-little-problem-with-puppet/
- http://secunia.com/advisories/59197
- http://secunia.com/advisories/59200
- http://www.securityfocus.com/bid/68035
- http://puppetlabs.com/security/cve/cve-2014-3248
- http://rowediness.com/2014/06/13/cve-2014-3248-a-little-problem-with-puppet/
- http://secunia.com/advisories/59197
- http://secunia.com/advisories/59200
- http://www.securityfocus.com/bid/68035
Get alerted when CVE-2014-3248 or the next vulnerability affects your stack