What’s Vulnerable › Vulnerabilities
CVE-2014-3250
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-295
Description
The default vhost configuration file in Puppet before 3.6.2 does not include the SSLCARevocationCheck directive, which might allow remote attackers to obtain sensitive information via a revoked certificate when a Puppet master runs with Apache 2.4.
Affected products
- Puppet Agent: before 3.6.2 — fixed in 3.6.2
- RedHat Linux: all versions
How to fix
Upgrade to a fixed version: Puppet Agent 3.6.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1101347
- https://puppet.com/security/cve/CVE-2014-3250
- https://bugzilla.redhat.com/show_bug.cgi?id=1101347
- https://puppet.com/security/cve/CVE-2014-3250
Get alerted when CVE-2014-3250 or the next vulnerability affects your stack