What’s Vulnerable › Vulnerabilities
CVE-2014-3462
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-07 · updated 2026-06-17
- Weakness: CWE-200
Description
The ".encfs6.xml" configuration file in encfs before 1.7.5 allows remote attackers to access sensitive data by setting "blockMACBytes" to 0 and adding 8 to "blockMACRandBytes".
Affected products
- Encfs Project Encfs: before 1.7.5 — fixed in 1.7.5
- openSUSE Leap: 42.1, 42.2
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: Encfs Project Encfs 1.7.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00090.html
- http://www.openwall.com/lists/oss-security/2014/05/14/2
- https://bugzilla.redhat.com/show_bug.cgi?id=1097537
- https://security.gentoo.org/glsa/201512-09
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00090.html
- http://www.openwall.com/lists/oss-security/2014/05/14/2
- https://bugzilla.redhat.com/show_bug.cgi?id=1097537
- https://security.gentoo.org/glsa/201512-09
Get alerted when CVE-2014-3462 or the next vulnerability affects your stack