What’s Vulnerable › Vulnerabilities
CVE-2014-3468
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-06-05 · updated 2026-06-17
- Weakness: CWE-131
Description
The asn1_get_bit_der function in GNU Libtasn1 before 3.6 does not properly report an error when a negative bit length is identified, which allows context-dependent attackers to cause out-of-bounds access via crafted ASN.1 data.
Affected products
- Debian Linux: 7.0
- F5 Arx Firmware: from 6.0.0 through 6.4.0
- [UNKNOWN] gnutls: before 3.5.7 — fixed in 3.5.7
- GnuTLS libtasn1: before 3.6 — fixed in 3.6
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Eus: 6.5, 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 6.5, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 6.5, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
- RedHat Virtualization: 6.0
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise High Availability Extension: 11-sp3
- SUSE Linux Enterprise Server: 11-sp1, 11-sp2, 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.5.7; GnuTLS libtasn1 3.6. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0247.html
- http://git.savannah.gnu.org/cgit/libtasn1.git/commit/?id=1c3ccb3e040bf13e342ee60bc23b21b97b11923f
- http://linux.oracle.com/errata/ELSA-2014-0594.html
- http://linux.oracle.com/errata/ELSA-2014-0596.html
- http://lists.gnu.org/archive/html/help-libtasn1/2014-05/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2014-06/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2014-06/msg00015.html
- http://rhn.redhat.com/errata/RHSA-2014-0594.html
- http://rhn.redhat.com/errata/RHSA-2014-0596.html
- http://rhn.redhat.com/errata/RHSA-2014-0687.html
- http://rhn.redhat.com/errata/RHSA-2014-0815.html
- http://secunia.com/advisories/58591
Get alerted when CVE-2014-3468 or the next vulnerability affects your stack