What’s Vulnerable › Vulnerabilities
CVE-2014-3473
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in the Horizon Orchestration dashboard in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2, when used with Heat, allows remote Orchestration template owners or catalogs to inject arbitrary web script or HTML via a crafted template.
Affected products
- OpenStack Horizon: from 2013.2 before 2013.2.4; from 2014.1 before 2014.1.2; juno-1 — fixed in 2013.2.4, 2014.1.2
- Opensuse: 13.1
How to fix
Upgrade to a fixed version: OpenStack Horizon 2013.2.4, 2014.1.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- http://www.openwall.com/lists/oss-security/2014/07/08/6
- http://www.securityfocus.com/bid/68459
- https://bugs.launchpad.net/horizon/+bug/1308727
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- http://www.openwall.com/lists/oss-security/2014/07/08/6
- http://www.securityfocus.com/bid/68459
- https://bugs.launchpad.net/horizon/+bug/1308727
Get alerted when CVE-2014-3473 or the next vulnerability affects your stack