What’s Vulnerable › Vulnerabilities

CVE-2014-3515

Description

The SPL component in PHP before 5.4.30 and 5.5.x before 5.5.14 incorrectly anticipates that certain data structures will have the array data type after unserialization, which allows remote attackers to execute arbitrary code via a crafted string that triggers use of a Hashtable destructor, related to "type confusion" issues in (1) ArrayObject and (2) SPLObjectStorage.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.3.29, 5.4.30, 5.5.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-3515 or the next vulnerability affects your stack