What’s Vulnerable › Vulnerabilities

CVE-2014-3538

Description

file before 5.19 does not properly restrict the amount of data read during a regex search, which allows remote attackers to cause a denial of service (CPU consumption) via a crafted file that triggers backtracking during processing of an awk rule. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7345.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.32, 5.5.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-3538 or the next vulnerability affects your stack