What’s Vulnerable › Vulnerabilities
CVE-2014-3554
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-07-31 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow in the ndp_msg_opt_dnssl_domain function in libndp allows remote routers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted DNS Search List (DNSSL) in an IPv6 router advertisement.
Affected products
- Libndp: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: Libndp 1.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/07/29/2
- http://www.securityfocus.com/bid/68945
- https://bugzilla.redhat.com/show_bug.cgi?id=1118583
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94927
- http://www.openwall.com/lists/oss-security/2014/07/29/2
- http://www.securityfocus.com/bid/68945
- https://bugzilla.redhat.com/show_bug.cgi?id=1118583
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94927
Get alerted when CVE-2014-3554 or the next vulnerability affects your stack