What’s Vulnerable › Vulnerabilities

CVE-2014-3558

Description

ReflectionHelper (org.hibernate.validator.util.ReflectionHelper) in Hibernate Validator 4.1.0 before 4.2.1, 4.3.x before 4.3.2, and 5.x before 5.1.2 allows attackers to bypass Java Security Manager (JSM) restrictions and execute restricted reflection calls via a crafted application.

Affected products

How to fix

Upgrade to a fixed version: Hibernate Validator 4.3.2, 5.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-3558 or the next vulnerability affects your stack