What’s Vulnerable › Vulnerabilities
CVE-2014-3581
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-10-10 · updated 2026-06-17
- Weakness: CWE-476
Description
The cache_merge_headers_out function in modules/cache/cache_util.c in the mod_cache module in the Apache HTTP Server before 2.4.11 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty HTTP Content-Type header.
Affected products
- Apache HTTP Server: 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.6, 2.4.7 (+2)
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Oracle Corporation Enterprise Manager Ops Center: before 12.1.4; 12.2.0, 12.2.1, 12.3.0 — fixed in 12.1.4
- Oracle Corporation Oracle Linux: 6
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
How to fix
Upgrade to a fixed version: Oracle Corporation Enterprise Manager Ops Center 12.1.4. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
- http://rhn.redhat.com/errata/RHSA-2015-0325.html
- http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/CHANGES?view=markup&pathrev=1627749
- http://svn.apache.org/viewvc?view=revision&revision=1624234
- http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://www.securityfocus.com/bid/71656
- http://www.securitytracker.com/id/1031005
- http://www.ubuntu.com/usn/USN-2523-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1149709
- https://exchange.xforce.ibmcloud.com/vulnerabilities/97027
Get alerted when CVE-2014-3581 or the next vulnerability affects your stack