What’s Vulnerable › Vulnerabilities
CVE-2014-3591
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-29 · updated 2026-06-17
- Weakness: CWE-200
Description
Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.
Affected products
- Debian Linux: 7.0, 8.0
- GnuPG: before 1.4.19 — fixed in 1.4.19
- gnupg Libgcrypt: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: GnuPG 1.4.19; gnupg Libgcrypt 1.6.3. Check the vendor advisory for mitigations.
References
- http://www.cs.tau.ac.il/~tromer/radioexp/
- http://www.debian.org/security/2015/dsa-3184
- http://www.debian.org/security/2015/dsa-3185
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000363.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000364.html
- http://www.cs.tau.ac.il/~tromer/radioexp/
- http://www.debian.org/security/2015/dsa-3184
- http://www.debian.org/security/2015/dsa-3185
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000363.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000364.html
Get alerted when CVE-2014-3591 or the next vulnerability affects your stack