What’s Vulnerable › Vulnerabilities
CVE-2014-3594
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.
Affected products
- OpenStack Horizon: from 2013.2 before 2013.2.4; from 2014.1 before 2014.1.2; juno-1, juno-2 — fixed in 2013.2.4, 2014.1.2
- Opensuse: 13.1
How to fix
Upgrade to a fixed version: OpenStack Horizon 2013.2.4, 2014.1.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- http://rhn.redhat.com/errata/RHSA-2014-1335.html
- http://rhn.redhat.com/errata/RHSA-2014-1336.html
- http://seclists.org/oss-sec/2014/q3/413
- http://www.securityfocus.com/bid/69291
- https://bugs.launchpad.net/horizon/+bug/1349491
- https://exchange.xforce.ibmcloud.com/vulnerabilities/95378
- https://review.openstack.org/#/c/115310
- https://review.openstack.org/#/c/115311
- https://review.openstack.org/#/c/115313/
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- http://rhn.redhat.com/errata/RHSA-2014-1335.html
Get alerted when CVE-2014-3594 or the next vulnerability affects your stack