What’s Vulnerable › Vulnerabilities
CVE-2014-3610
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-11-10 · updated 2026-06-17
Description
The WRMSR processing functionality in the KVM subsystem in the Linux kernel through 3.17.2 does not properly handle the writing of a non-canonical address to a model-specific register, which allows guest OS users to cause a denial of service (host OS crash) by leveraging guest OS privileges, related to the wrmsr_interception function in arch/x86/kvm/svm.c and the handle_wrmsr function in arch/x86/kvm/vmx.c.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04
- Debian Linux: 7.0
- Linux kernel: before 3.17.2 — fixed in 3.17.2
- openSUSE Evergreen: 11.4
- SUSE Linux Enterprise: 11-sp2
How to fix
Upgrade to a fixed version: Linux kernel 3.17.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=854e8bb1aa06c578c2c9145fa6bfe3680ef63b23
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://rhn.redhat.com/errata/RHSA-2015-0869.html
- http://www.debian.org/security/2014/dsa-3060
- http://www.openwall.com/lists/oss-security/2014/10/24/9
- http://www.securityfocus.com/bid/70742
- http://www.ubuntu.com/usn/USN-2394-1
- http://www.ubuntu.com/usn/USN-2417-1
- http://www.ubuntu.com/usn/USN-2418-1
- http://www.ubuntu.com/usn/USN-2491-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1144883
Get alerted when CVE-2014-3610 or the next vulnerability affects your stack