What’s Vulnerable › Vulnerabilities
CVE-2014-3622
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-19 · updated 2026-06-17
- Weakness: CWE-416
Description
Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.
Affected products
- PHP: from 5.6.0 before 5.6.1 — fixed in 5.6.1
How to fix
Upgrade to a fixed version: PHP 5.6.1. Check the vendor advisory for mitigations.
References
- http://php.net/ChangeLog-5.php
- https://bugs.php.net/bug.php?id=68088
- https://bugzilla.redhat.com/show_bug.cgi?id=1151423
- http://php.net/ChangeLog-5.php
- https://bugs.php.net/bug.php?id=68088
- https://bugzilla.redhat.com/show_bug.cgi?id=1151423
Get alerted when CVE-2014-3622 or the next vulnerability affects your stack