What’s Vulnerable › Vulnerabilities
CVE-2014-3681
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-10-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected products
How to fix
Upgrade to a fixed version: Jenkins 1.565.3, 1.583. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2016:0070
- https://bugzilla.redhat.com/show_bug.cgi?id=1147766
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96975
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01
- https://access.redhat.com/errata/RHSA-2016:0070
- https://bugzilla.redhat.com/show_bug.cgi?id=1147766
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96975
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01
Get alerted when CVE-2014-3681 or the next vulnerability affects your stack