What’s Vulnerable › Vulnerabilities
CVE-2014-3690
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-10 · updated 2026-06-17
- Weakness: CWE-400
Description
arch/x86/kvm/vmx.c in the KVM subsystem in the Linux kernel before 3.17.2 on Intel processors does not ensure that the value in the CR4 control register remains the same after a VM entry, which allows host OS users to kill arbitrary processes or cause a denial of service (system disruption) by leveraging /dev/kvm access, as demonstrated by PR_SET_TSC prctl calls within a modified copy of QEMU.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0
- Linux kernel: before 3.17.2 — fixed in 3.17.2
- Novell Suse Linux Enterprise Desktop: 12.0
- Novell Suse Linux Enterprise Server: 11-sp2, 12.0
- openSUSE Evergreen: 11.4
- Red Hat Enterprise Linux: 5.0
- SUSE Linux Enterprise Real Time Extension: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 12
- SUSE Linux Enterprise Workstation Extension: 12
How to fix
Upgrade to a fixed version: Linux kernel 3.17.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d974baa398f34393db76be45f7d4d04fbdbb4a0a
- http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00015.html
- http://rhn.redhat.com/errata/RHSA-2015-0290.html
- http://rhn.redhat.com/errata/RHSA-2015-0782.html
- http://rhn.redhat.com/errata/RHSA-2015-0864.html
- http://secunia.com/advisories/60174
- http://www.debian.org/security/2014/dsa-3060
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.17.2
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:058
Get alerted when CVE-2014-3690 or the next vulnerability affects your stack