What’s Vulnerable › Vulnerabilities
CVE-2014-3704
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-10-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The expandArguments function in the database abstraction API in Drupal core 7.x before 7.32 does not properly construct prepared statements, which allows remote attackers to conduct SQL injection attacks via an array containing crafted keys.
Affected products
- Debian Linux: 7.0
- Drupal: from 7.0 before 7.32 — fixed in 7.32
How to fix
Upgrade to a fixed version: Drupal 7.32. Check the vendor advisory for mitigations.
References
- http://osvdb.org/show/osvdb/113371
- http://packetstormsecurity.com/files/128720/Drupal-7.X-SQL-Injection.html
- http://packetstormsecurity.com/files/128721/Drupal-7.31-SQL-Injection.html
- http://packetstormsecurity.com/files/128741/Drupal-HTTP-Parameter-Key-Value-SQL-Injection.html
- http://seclists.org/fulldisclosure/2014/Oct/75
- http://secunia.com/advisories/59972
- http://www.debian.org/security/2014/dsa-3051
- http://www.exploit-db.com/exploits/34984
- http://www.exploit-db.com/exploits/34992
- http://www.exploit-db.com/exploits/34993
- http://www.exploit-db.com/exploits/35150
- http://www.openwall.com/lists/oss-security/2014/10/15/23
Get alerted when CVE-2014-3704 or the next vulnerability affects your stack