What’s Vulnerable › Vulnerabilities
CVE-2014-3743
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Affected products
- markedjs marked: before 0.3.1 — fixed in 0.3.1
How to fix
Upgrade to a fixed version: markedjs marked 0.3.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-3743
- https://nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilities
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-3743
- https://nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilities
Get alerted when CVE-2014-3743 or the next vulnerability affects your stack