What’s Vulnerable › Vulnerabilities

CVE-2014-4049

Description

Heap-based buffer overflow in the php_parserr function in ext/standard/dns.c in PHP 5.6.0beta4 and earlier allows remote servers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted DNS TXT record, related to the dns_get_record function.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.3.29, 5.4.30, 5.5.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-4049 or the next vulnerability affects your stack