What’s Vulnerable › Vulnerabilities
CVE-2014-4341
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-07-20 · updated 2026-06-17
- Weakness: CWE-125
Description
MIT Kerberos 5 (aka krb5) before 1.12.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) by injecting invalid tokens into a GSSAPI application session.
Affected products
- Debian Linux: 7.0
- Fedoraproject Fedora: 20
- MIT Kerberos 5: before 1.12.2 — fixed in 1.12.2
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.12.2. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0345.html
- http://aix.software.ibm.com/aix/efixes/security/nas_advisory1.asc
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=7949
- http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136360.html
- http://rhn.redhat.com/errata/RHSA-2015-0439.html
- http://secunia.com/advisories/59102
- http://secunia.com/advisories/60082
- http://secunia.com/advisories/60448
- http://security.gentoo.org/glsa/glsa-201412-53.xml
- http://www.debian.org/security/2014/dsa-3000
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:165
- http://www.securityfocus.com/bid/68909
Get alerted when CVE-2014-4341 or the next vulnerability affects your stack