What’s Vulnerable › Vulnerabilities
CVE-2014-4608
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-07-03 · updated 2026-06-17
- Weakness: CWE-190
Description
Multiple integer overflows in the lzo1x_decompress_safe function in lib/lzo/lzo1x_decompress_safe.c in the LZO decompressor in the Linux kernel before 3.15.2 allow context-dependent attackers to cause a denial of service (memory corruption) via a crafted Literal Run. NOTE: the author of the LZO algorithms says "the Linux kernel is *not* affected; media hype.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Linux kernel: before 3.15.2 — fixed in 3.15.2
- Opensuse: 11.4
- SUSE Linux Enterprise Real Time Extension: 11-sp3
- SUSE Linux Enterprise Server: 11-sp2
How to fix
Upgrade to a fixed version: Linux kernel 3.15.2. Check the vendor advisory for mitigations.
References
- http://blog.securitymouse.com/2014/06/raising-lazarus-20-year-old-bug-that.html
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=206a81c18401c0cde6e579164f752c4b147324ce
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00015.html
- http://rhn.redhat.com/errata/RHSA-2015-0062.html
- http://secunia.com/advisories/60011
- http://secunia.com/advisories/60174
- http://secunia.com/advisories/62633
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.15.2
- http://www.oberhumer.com/opensource/lzo/
- http://www.openwall.com/lists/oss-security/2014/06/26/21
Get alerted when CVE-2014-4608 or the next vulnerability affects your stack