What’s Vulnerable › Vulnerabilities
CVE-2014-4611
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-07-03 · updated 2026-06-17
- Weakness: CWE-20
Description
Integer overflow in the LZ4 algorithm implementation, as used in Yann Collet LZ4 before r118 and in the lz4_uncompress function in lib/lz4/lz4_decompress.c in the Linux kernel before 3.15.2, on 32-bit platforms might allow context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted Literal Run that would be improperly handled by programs not complying with an API limitation, a different vulnerability than CVE-2014-4715.
Affected products
- Linux kernel: before 3.15.2 — fixed in 3.15.2
How to fix
Upgrade to a fixed version: Linux kernel 3.15.2. Check the vendor advisory for mitigations.
References
- http://blog.securitymouse.com/2014/06/raising-lazarus-20-year-old-bug-that.html
- http://fastcompression.blogspot.fr/2014/06/debunking-lz4-20-years-old-bug-myth.html
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=206204a1162b995e2185275167b22468c00d6b36
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00025.html
- http://secunia.com/advisories/59567
- http://secunia.com/advisories/59770
- http://secunia.com/advisories/60238
- http://twitter.com/djrbliss/statuses/484931749013495809
- http://twitter.com/djrbliss/statuses/485042901399789568
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.15.2
- http://www.openwall.com/lists/oss-security/2014/06/26/24
- http://www.securitytracker.com/id/1030491
Get alerted when CVE-2014-4611 or the next vulnerability affects your stack