What’s Vulnerable › Vulnerabilities
CVE-2014-4616
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-08-24 · updated 2026-06-17
- Weakness: CWE-129
Description
Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.
Affected products
- Opensuse: 13.1
- Opensuse Project Opensuse: 12.3
- Python: from 2.7.0 before 2.7.7; from 3.0.0 before 3.2.6; from 3.3.0 before 3.3.6; from 3.4.0 before 3.4.1 — fixed in 2.7.7, 3.2.6, 3.3.6, 3.4.1
- Simplejson Project Simplejson: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: Python 2.7.7, 3.2.6, 3.3.6, 3.4.1; Simplejson Project Simplejson 2.6.1. Check the vendor advisory for mitigations.
References
- http://bugs.python.org/issue21529
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00015.html
- http://openwall.com/lists/oss-security/2014/06/24/7
- http://rhn.redhat.com/errata/RHSA-2015-1064.html
- http://www.securityfocus.com/bid/68119
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752395
- https://bugzilla.redhat.com/show_bug.cgi?id=1112285
- https://hackerone.com/reports/12297
- https://security.gentoo.org/glsa/201503-10
- http://bugs.python.org/issue21529
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00015.html
- http://openwall.com/lists/oss-security/2014/06/24/7
Get alerted when CVE-2014-4616 or the next vulnerability affects your stack