What’s Vulnerable › Vulnerabilities
CVE-2014-4650
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-20 · updated 2026-06-17
- Weakness: CWE-22
Description
The CGIHTTPServer module in Python 2.7.5 and 3.3.4 does not properly handle URLs in which URL encoding is used for path separators, which allows remote attackers to read script source code or conduct directory traversal attacks and execute unintended code via a crafted character sequence, as demonstrated by a %2f separator.
Affected products
- Python: from 2.7.0 before 2.7.8; from 3.2.0 before 3.2.6; from 3.3.0 before 3.3.6; from 3.4.0 before 3.4.2 — fixed in 2.7.8, 3.2.6, 3.3.6, 3.4.2
- Red Hat Enterprise Linux: 5.0, 6.0, 7.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: Python 2.7.8, 3.2.6, 3.3.6, 3.4.2. Check the vendor advisory for mitigations.
References
- http://bugs.python.org/issue21766
- http://openwall.com/lists/oss-security/2014/06/26/3
- https://access.redhat.com/security/cve/cve-2014-4650
- http://bugs.python.org/issue21766
- http://openwall.com/lists/oss-security/2014/06/26/3
- https://access.redhat.com/security/cve/cve-2014-4650
Get alerted when CVE-2014-4650 or the next vulnerability affects your stack