What’s Vulnerable › Vulnerabilities
CVE-2014-4657
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-20 · updated 2026-06-17
- Weakness: CWE-20
Description
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Affected products
- Red Hat Ansible: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://www.securityfocus.com/bid/68232
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://www.securityfocus.com/bid/68232
Get alerted when CVE-2014-4657 or the next vulnerability affects your stack