What’s Vulnerable › Vulnerabilities
CVE-2014-4658
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-20 · updated 2026-06-17
- Weakness: CWE-200
Description
The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.
Affected products
- Red Hat Ansible: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.5.5. Check the vendor advisory for mitigations.
References
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://www.securityfocus.com/bid/68233
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://www.securityfocus.com/bid/68233
Get alerted when CVE-2014-4658 or the next vulnerability affects your stack