What’s Vulnerable › Vulnerabilities
CVE-2014-4678
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-20 · updated 2026-06-17
- Weakness: CWE-74
Description
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Red Hat Ansible: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/ansible/ansible/commit/5429b85b9f6c2e640074176f36ff05fd5e4d1916
- https://groups.google.com/forum/message/raw?msg=ansible-announce/ieV1vZvcTXU/5Q93ThkY9rIJ
- https://security-tracker.debian.org/tracker/CVE-2014-4678
- https://www.openwall.com/lists/oss-security/2014/06/26/30
- https://www.openwall.com/lists/oss-security/2014/07/02/2
- https://www.rapid7.com/db/vulnerabilities/freebsd-vid-2c493ac8-205e-11e5-a4a5-002590263bf5
- https://www.rapid7.com/db/vulnerabilities/gentoo-linux-cve-2014-4678
- https://github.com/ansible/ansible/commit/5429b85b9f6c2e640074176f36ff05fd5e4d1916
- https://groups.google.com/forum/message/raw?msg=ansible-announce/ieV1vZvcTXU/5Q93ThkY9rIJ
- https://security-tracker.debian.org/tracker/CVE-2014-4678
- https://www.openwall.com/lists/oss-security/2014/06/26/30
- https://www.openwall.com/lists/oss-security/2014/07/02/2
Get alerted when CVE-2014-4678 or the next vulnerability affects your stack