What’s Vulnerable › Vulnerabilities
CVE-2014-4699
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-07-09 · updated 2026-06-17
- Weakness: CWE-362
Description
The Linux kernel before 3.15.4 on Intel processors does not properly restrict use of a non-canonical value for the saved RIP address in the case of a system call that does not use IRET, which allows local users to leverage a race condition and gain privileges, or cause a denial of service (double fault), via a crafted application that makes ptrace and fork system calls.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 13.10, 14.04
- Debian Linux: 7.0
- Linux kernel: from 2.6.17 before 3.2.61; from 3.3 before 3.4.97; from 3.5 before 3.10.47; from 3.11 before 3.12.25; from 3.13 before 3.14.11; from 3.15 before 3.15.4 — fixed in 3.10.47, 3.12.25, 3.14.11, 3.15.4, 3.2.61, 3.4.97
How to fix
Upgrade to a fixed version: Linux kernel 3.10.47, 3.12.25, 3.14.11, 3.15.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=b9cd18de4db3c9ffa7e17b0dc0ca99ed5aa4d43a
- http://linux.oracle.com/errata/ELSA-2014-0924.html
- http://linux.oracle.com/errata/ELSA-2014-3047.html
- http://linux.oracle.com/errata/ELSA-2014-3048.html
- http://openwall.com/lists/oss-security/2014/07/05/4
- http://openwall.com/lists/oss-security/2014/07/08/16
- http://openwall.com/lists/oss-security/2014/07/08/5
- http://packetstormsecurity.com/files/127573/Linux-Kernel-ptrace-sysret-Local-Privilege-Escalation.html
- http://secunia.com/advisories/59633
- http://secunia.com/advisories/59639
- http://secunia.com/advisories/59654
- http://secunia.com/advisories/60220
Get alerted when CVE-2014-4699 or the next vulnerability affects your stack