What’s Vulnerable › Vulnerabilities

CVE-2014-4721

Description

The phpinfo implementation in ext/standard/info.c in PHP before 5.4.30 and 5.5.x before 5.5.14 does not ensure use of the string data type for the PHP_AUTH_PW, PHP_AUTH_TYPE, PHP_AUTH_USER, and PHP_SELF variables, which might allow context-dependent attackers to obtain sensitive information from process memory by using the integer data type with crafted values, related to a "type confusion" vulnerability, as demonstrated by reading a private SSL key in an Apache HTTP Server web-hosting environment with mod_ssl and a PHP 5.3.x mod_php.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.3.29, 5.4.30, 5.5.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-4721 or the next vulnerability affects your stack