What’s Vulnerable › Vulnerabilities
CVE-2014-4914
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-29 · updated 2026-06-17
- Weakness: CWE-89
Description
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
Affected products
- Debian Linux: 7.0, 8.0
- Zend Technologies Zend Framework: before 1.12.7 — fixed in 1.12.7
How to fix
Upgrade to a fixed version: Zend Technologies Zend Framework 1.12.7. Check the vendor advisory for mitigations.
References
- http://framework.zend.com/security/advisory/ZF2014-04
- http://jvn.jp/en/jp/JVN71730320/index.html
- http://openwall.com/lists/oss-security/2014/07/11/4
- http://secunia.com/advisories/58847
- http://www.securityfocus.com/bid/68031
- https://www.debian.org/security/2015/dsa-3265
- http://framework.zend.com/security/advisory/ZF2014-04
- http://jvn.jp/en/jp/JVN71730320/index.html
- http://openwall.com/lists/oss-security/2014/07/11/4
- http://secunia.com/advisories/58847
- http://www.securityfocus.com/bid/68031
- https://www.debian.org/security/2015/dsa-3265
Get alerted when CVE-2014-4914 or the next vulnerability affects your stack