What’s Vulnerable › Vulnerabilities
CVE-2014-4966
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-18 · updated 2026-06-17
- Weakness: CWE-74
Description
Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.
Affected products
- Red Hat Ansible: before 1.6.7 — fixed in 1.6.7
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.6.7. Check the vendor advisory for mitigations.
References
- http://www.ocert.org/advisories/ocert-2014-004.html
- https://github.com/ansible/ansible/commit/62a1295a3e08cb6c3e9f1b2a1e6e5dcaeab32527
- http://www.ocert.org/advisories/ocert-2014-004.html
- https://github.com/ansible/ansible/commit/62a1295a3e08cb6c3e9f1b2a1e6e5dcaeab32527
Get alerted when CVE-2014-4966 or the next vulnerability affects your stack