What’s Vulnerable › Vulnerabilities
CVE-2014-4967
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-18 · updated 2026-06-17
- Weakness: CWE-74
Description
Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.
Affected products
- Red Hat Ansible: before 1.6.7 — fixed in 1.6.7
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.6.7. Check the vendor advisory for mitigations.
References
- http://www.ocert.org/advisories/ocert-2014-004.html
- https://github.com/ansible/ansible/commit/62a1295a3e08cb6c3e9f1b2a1e6e5dcaeab32527
- http://www.ocert.org/advisories/ocert-2014-004.html
- https://github.com/ansible/ansible/commit/62a1295a3e08cb6c3e9f1b2a1e6e5dcaeab32527
Get alerted when CVE-2014-4967 or the next vulnerability affects your stack