What’s Vulnerable › Vulnerabilities
CVE-2014-5002
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-10 · updated 2026-06-17
- Weakness: CWE-255
Description
The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.
Affected products
- Lynx Project Lynx: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Lynx Project Lynx 1.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/07/07/23
- http://www.openwall.com/lists/oss-security/2014/07/17/5
- http://www.vapid.dhs.org/advisories/lynx-0.2.0.html
- https://github.com/panthomakos/lynx/issues/3
- http://www.openwall.com/lists/oss-security/2014/07/07/23
- http://www.openwall.com/lists/oss-security/2014/07/17/5
- http://www.vapid.dhs.org/advisories/lynx-0.2.0.html
- https://github.com/panthomakos/lynx/issues/3
Get alerted when CVE-2014-5002 or the next vulnerability affects your stack