What’s Vulnerable › Vulnerabilities
CVE-2014-5044
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-07 · updated 2026-06-17
- Weakness: CWE-190
Description
Multiple integer overflows in libgfortran might allow remote attackers to execute arbitrary code or cause a denial of service (Fortran application crash) via vectors related to array allocation.
Affected products
- GNU Libgfortran: before 4.8 — fixed in 4.8
How to fix
Upgrade to a fixed version: GNU Libgfortran 4.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/07/24/1
- http://www.openwall.com/lists/oss-security/2014/07/31/6
- https://bugzilla.redhat.com/show_bug.cgi?id=1122812
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94849
- https://gcc.gnu.org/viewcvs/gcc/trunk/libgfortran/ChangeLog?limit_changes=0&view=markup&pathrev=211721
- http://www.openwall.com/lists/oss-security/2014/07/24/1
- http://www.openwall.com/lists/oss-security/2014/07/31/6
- https://bugzilla.redhat.com/show_bug.cgi?id=1122812
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94849
- https://gcc.gnu.org/viewcvs/gcc/trunk/libgfortran/ChangeLog?limit_changes=0&view=markup&pathrev=211721
Get alerted when CVE-2014-5044 or the next vulnerability affects your stack