What’s Vulnerable › Vulnerabilities
CVE-2014-5086
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-10 · updated 2026-06-17
- Weakness: CWE-74
Description
A Command Execution vulnerability exists in Sphider Pro, and Sphider Plus 3.2 due to insufficient sanitization of fwrite to conf.php, which could let a remote malicious user execute arbitrary code. CVE-2014-5086 pertains to instances of fwrite in Sphider Pro and Sphider Plus only, but don’t exist in Sphider.
Affected products
- Sphider: before 1.3.6 — fixed in 1.3.6
- Sphider-Plus: before 3.2 — fixed in 3.2
- Sphiderpro Sphider Pro: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: Sphider 1.3.6; Sphider-Plus 3.2; Sphiderpro Sphider Pro 3.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/127720/Sphider-Search-Engine-Command-Execution-SQL-Injection.html
- http://packetstormsecurity.com/files/127720/Sphider-Search-Engine-Command-Execution-SQL-Injection.html
Get alerted when CVE-2014-5086 or the next vulnerability affects your stack