What’s Vulnerable › Vulnerabilities
CVE-2014-5087
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-07 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability exists in Sphider Search Engine prior to 1.3.6 due to exec calls in admin/spiderfuncs.php, which could let a remote malicious user execute arbitrary code.
Affected products
- Sphider: before 1.3.6 — fixed in 1.3.6
- Sphider-Plus: before 3.2 — fixed in 3.2
- Sphiderpro Sphider Pro: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: Sphider 1.3.6; Sphider-Plus 3.2; Sphiderpro Sphider Pro 3.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/127720/Sphider-Search-Engine-Command-Execution-SQL-Injection.html
- https://vulmon.com/searchpage?page=2&q=Shayan+S
- http://packetstormsecurity.com/files/127720/Sphider-Search-Engine-Command-Execution-SQL-Injection.html
- https://vulmon.com/searchpage?page=2&q=Shayan+S
Get alerted when CVE-2014-5087 or the next vulnerability affects your stack