What’s Vulnerable › Vulnerabilities
CVE-2014-5119
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-08-29 · updated 2026-06-17
- Weakness: CWE-189
Description
Off-by-one error in the __gconv_translit_find function in gconv_trans.c in GNU C Library (aka glibc) allows context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via vectors related to the CHARSET environment variable and gconv transliteration modules.
Affected products
- Debian Linux: 7.0
- GNU C Library (glibc): before 2.20 — fixed in 2.20
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.20. Check the vendor advisory for mitigations.
References
- http://googleprojectzero.blogspot.com/2014/08/the-poisoned-nul-byte-2014-edition.html
- http://linux.oracle.com/errata/ELSA-2015-0092.html
- http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00017.html
- http://rhn.redhat.com/errata/RHSA-2014-1118.html
- http://seclists.org/fulldisclosure/2014/Aug/69
- http://secunia.com/advisories/60345
- http://secunia.com/advisories/60358
- http://secunia.com/advisories/60441
- http://secunia.com/advisories/61074
- http://secunia.com/advisories/61093
- http://tools.cisco.com/security/center/content/CiscoSecurityNotice/CVE-2014-5119
- http://www-01.ibm.com/support/docview.wss?uid=swg21685604
Get alerted when CVE-2014-5119 or the next vulnerability affects your stack